Report Services Miscellaneous Report Troubleshooting

The following sections include various troubleshooting tips for Reporting Services.

Reporting Services Tips

If you are having difficulty getting a specific report to run, before you do anything else, try to run other reports and see if other reports are getting the same error. If every report is getting the same error, then you have a global issue to deal with. Typically this entails an RAS issue, a user login or configuration issue, or a web server issue, as opposed to a local issue on your single report.

My Excel Reports Return no Data

If you are having problems returning a specific report in Excel often it is a result of a large row count. As of writing, MSRS supports output to Microsoft Excel 2003 which has a built in limitation of 65536 rows and 256 columns. In your event log, this will create an rrRenderingError, and can be confirmed by a ByteCount of 0 and a RowCount of greater than 65536. Excel 2007 does not have this row limit.

Page Not Found on Export

Error: run a list/query, export to ASCII/CSV, get a network logon prompt and get "page cannot be found" error:

Possible Solution: What I saw was that it was requesting a login, and in the configuration of the iWeb directory, it had both a domain and realm specified — not sure why, we don't ever set it up that way, or we aren't supposed to.  I changed it to just a domain, and it seems to work.

Error: when attempting to export a queried list to an ASCII file a window pops up as if it is going to export but it disappears and nothing happens.

Possible Solution: there are two solutions to this issue. you can either:

Hold down the CTRL key during the process of exporting the query to an ASCII file.
Add your site address to the local intranet under the internet options .

All Reports Return a Blank Page

Error: all reports are bringing back a blank page

Possible Solution: sometimes Windows runs an automatic update which changes the authentication settings on the Report Server. To fix the problem you must reconfigure the authentication settings.